Dev Portal Digital Asset Manager may cause high CPU utilization

Incident Report for Filestack

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 03:44 UTC

Identified

Some may experience high CPU utilization when using the Digital Asset Manager in the Filestack Dev Portal. The issue has been identified and our teams are working to release a fix as soon as possible.
Posted Jul 19, 2025 - 00:13 UTC
This incident affected: Developer Portal.